Topic: Audio output channels (CoreAudio)

Hi. First of all, congratulations for this amazing player. However, there's a problem which prevents me from using it.

I have a 4 channel sound card (Native Instruments Audio 4 DJ - USB), Core Audio compatible. I mean, my soundcard has two independent stereo outputs.

I'm running Mac OS-X Leopard 10.5.7, with the latest drivers for my soundcard. My system is a MacBook 13" White SantaRosa.

For some reasons I would rather not discuss in this thread, I need the second stereo output to be the default audio output of my system. I've successfully done this using the "Audio MIDI setup" utility. I just set "stereo speakers" in the "configure speakers" section, and assigned the left channel to the 3rd channel of my soundcard, and the right channel to the 4th channel.

This setup works pretty well with all other apps: iTunes, QuickTime, Firefox, Safari... except with Cog. No mather what I try, Cog only plays in the first stereo output of my soundcard (channels 1-2).

I've tried SoundFlower to route my audio channels, but this application makes my system unstable, and the audio driver crashes often.

Is there any way to configure Cog so that it would use the second stereo output of my soundcard (I mean, channels 3-4)?

Would be too much to ask for a way to configure this in Cog, or making it use my system's preferences?

Thank you.

Re: Audio output channels (CoreAudio)

I have the same problem. The

Re: Audio output channels (CoreAudio)

Yesterday, I downloaded the nightly build. I've noticed some great improvements in the user interface. This player is becoming great.

But, again, unless I'm able to configure the audio outputs, it's useless for me. I'm willing to help in wathever I can.

Thank you.

Re: Audio output channels (CoreAudio)

I'm not sure why this is happening. Since I lack such a setup, I tried experimenting with SoundFlower to see if I could get this to happen.

I set the 16 channel device to use the Built in output, and modified all of the channels so channel 8 was forwarding to output[1] and channel 9 was forwarding to output[2]. I then set Cog's preferences to use the device, and Cog played silence. Which seems correct, since my stereo speakers in Audio MIDI Setup were set to 1 and 2. So, I changed the stereo speakers in the Audio MIDI Setup to use channels 8 and 9 and Cog played just fine.

Is there a setup with SoundFlower that gets this issue to occur?

EDIT: OK. I think I know the problem. Cog does no channel mapping and CoreAudio doesn't know enough to use the default. Fixing this may require architectural changes.

Last edited by vspader (2009-06-28 09:15:40)

Re: Audio output channels (CoreAudio)

I think architectural changes are not necessary. All you have to do is add a simple option to use the "system default output device". One can easily map the desired outputs using the Mac OS-X "Audio and MIDI setup" application.

Here's a screenshot of a program that implement this: http://twitpic.com/ugl6j

C'mon, please implement this. I like Cog a lot, but for now it's unusable for me. It's the only application I know that doesn't use the system default ouput device.

Re: Audio output channels (CoreAudio)

I don't know how to explain, but I've downloaded the latest night build (r1934) and it worked! There's no option "system default output device", but I selected my multichannel audio card as output, and it used the right output I've mapped in OS-X's "Audio and MIDI setup application".

But I still think there should be an option to use the "system default output device", for coherence.

Thank you, Cog is becoming greater everyday. It's currently my default audio player.

Re: Audio output channels (CoreAudio)

Right, it should work now, but it's very very ugly. If I remember right, output is always assumed to be just two channels now. Gross, yes, but it works for most cases.