Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Topic: audio files are not visible in the list

This problem has only become known to me in the past few days and i'm not sure why its happening.

When i load Cog, and add a new album to the playlist, none of the items are visible in the list. However, the total minutes of all the songs are shown at the bottom and when i click 'forward' button the song plays.

Heres what i looks like, http://img296.imageshack.us/img296/8666/picture1ig9.png



I'm running Cog 0.7 on Mac OS Leopard 10.5.1

Last edited by teckoda (2007-12-29 08:01:47)

Re: audio files are not visible in the list

I've gotten another report of this. Very very strange. Delete the  preferences files in ~/Library/Preferences/, both com.vspader.cog.plist and org.cogx.cog.plist, and things should work again.

Re: audio files are not visible in the list

That happened to me this morning.. No idea why, I didn't change anything.

Re: audio files are not visible in the list

I have switched back to 0.6 for the time being.. strange indeed.

Re: audio files are not visible in the list

Deleting the preferences does not fix the problem?


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Re: audio files are not visible in the list

Same problem here. Deleting the preferences files does the job.

FYI: I got this error in the console window:
1/3/08 3:49:40 PM Cog[13831] *** -[NSCFArray objectAtIndex:]: index (-1( or possibly larger)) beyond bounds (1)

Furthermore, as in the screenshot above i got no properties for the list, so maybe it has something to do with an error reading ID3 tags?

Re: audio files are not visible in the list

Likely it's a conflict with the removable columns code and Leopard. Leopard added support for removable columns, and I think the old code may be conflicting.

Re: audio files are not visible in the list

I had this problem, too. I believe that the issue may be related to me sorting and dragging columns. I was sorting on 'Track' when this occurred.

Deleting preferences did the trick.

OS X Leopard
Macbook Pro

Re: audio files are not visible in the list

Thanks! I'll try to reproduce it by doing that.

Re: audio files are not visible in the list

Yeah deleting the preference files did the trick alright.

Re: audio files are not visible in the list

Hello new here & also a new MAC & OSX Leopard user.
I was really loving COG for FLAC & SHN playback but started having the exact problem as described here yesterday.
I tried deleting the preference files described above as a fix but could not find them.

Can someone help me figure this out, with the approach that I am a total beginner dimwit?
thanks!!

Re: audio files are not visible in the list

Were you able to locate the preferences directory? ~/Library/Preferences? The ~ means your home directory.

You open a new finder window, go to Library, then go to Preferences, and look for those two files (com.vspader.cog.plist and org.cogx.cog.plist) and drag them to the trash. The .plist extension may be hidden, depending on how things are configured, so if you see just com.vspader.cog and org.cogx.cog, delete those too.

Does that help? Also, running Terminal and copying/pasting in the following should work:

rm ~/Library/Preferences/com.vspader.cog.plist ~/Library/Preferences/org.cogx.cog.plist

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Re: audio files are not visible in the list

vspader wrote:

Thanks! I'll try to reproduce it by doing that.

Just an update. I got a test case from robotron2084 and was able to duplicate it. I haven't been able to reproduce it with the latest build though, so it has been inadvertently fixed. I think it only affects Leopard users, since I haven't been able to reproduce it on 10.4. In any case, I hope to get a nightly build out there somewhat soon, which should work for the Leopard users.

Re: audio files are not visible in the list

thanks I did locate my preferences folder in the finder, but could not find those files, I even did a search for them.
I will try again, thank you for your help!

Re: audio files are not visible in the list

I had the same issue and was able to fix it by deleting ~/Library/Preferences/org.cogx.cog.plist (the other file wasn't present).

I was sorting by Title as well.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/cogx/cogx.org/forums/include/parser.php on line 738

Re: audio files are not visible in the list

I believe this was fixed with the 0.07 'Unstable' builds:

http://cogx.org/forums/viewtopic.php?id=325


Closing.