Topic: Cog 0.07 Doesn't Show Tags

This is my first post. I looked around before posting, trying to find an answer, and I didn't seem to be able to. So here goes. Sorry if this is old territory.

I just spent quite awhile tagging FLAC files using sbooth's "Tag." But when I opened the files up in Cog, none of the information showed, just the title and length. No Album, Artist, Track Number, nothing. I also looked at some FLAC files in Tag that were heavily tagged, yet they also show nothing when I open them in Cog.

I looked at a previous forum post and it said to trash a cog plist file in my home preferences folder, so I did, but that didn't solve the problem.

What's the problem? TIA for any insight. By the way, I am using Mac OS 10.4.11.

Last edited by Noodler (2010-09-18 12:03:05)

Re: Cog 0.07 Doesn't Show Tags

hmm.. I don't know if this solves the problem but I already experienced this:
in my tagging-app the files had some tags, but in cog they wouldnt show.. so I "rewrote" the tags and voilà, there they were.. (and again, I'm using the nightly build)

Last edited by arghwhymustiregister (2010-09-23 14:12:32)

Re: Cog 0.07 Doesn't Show Tags

What tagging app were you using? Maybe I'll try it. I used "Tag" by sbooth. Perhaps you have a better one in mind. If I have to re-tag, it will take a lot of work. I'm not looking forward to it, but I'll try!

Thanks again.

Re: Cog 0.07 Doesn't Show Tags

I am also having a similar issue.

It appears that some of my FLAC files written with an older version of FLAC using EAC (I encoded back in 2003) will not play nor will the Tags be recognized.

Other files on the same drive work fine. 

The same files will play correctly with VLC on my MAC and foobar 2000 under windows.

Last edited by campbrs (2010-09-27 08:55:55)

Re: Cog 0.07 Doesn't Show Tags

I have noticed this issue with newer FLAC's as well (i.e The Beatles USB -> Rubber Soul)

Could it be an unsupported character issue within the tag?

Re: Cog 0.07 Doesn't Show Tags

I use Tag and haven't noticed any problems, however I run Cog 0.08.

Max is favourite for CD ripping.

Re: Cog 0.07 Doesn't Show Tags

Last edited by arghwhymustiregister (2010-10-12 13:11:37)

Re: Cog 0.07 Doesn't Show Tags

Thanks for the messages.

I may try the nightly build, but in all honesty, I have found another App that I've been using regularly instead of Cog.

I'm using Vox right now and like it a lot. I may go back to revisiting Cog but right now, Vox has been close to 100% satisfying. I will take a look at that other tagging app, though. Thanks for the info.


Re: Cog 0.07 Doesn't Show Tags

The latest dev build worked!  Thanks!!!

Re: Cog 0.07 Doesn't Show Tags

Actually - The latest dev build is still having this issue - albiet to a smaller extent.  Most of my files do show up but some still do not work.  The files that don't work seem to be listed intermittenly (some times they show up in Cog and sometimes they don't)

They are mainly FLAC with tags - a total of 37K files accessed from a Airport Extreme Shared volume.

Any ideas?